Back to overview
Downtime
Performance impacted
Apr 19, 2026 at 12:05pm UTC
Affected services
safestream-link
PLEX-4
Resolved
Apr 25, 2026 at 12:01pm UTC
Running stable again.
Affected services
Updated
Apr 25, 2026 at 8:24am UTC
Modifications to the server infrastructure require a longer shutdown. We expect to be back online in about 3 hours.
Affected services
Created
Apr 19, 2026 at 12:05pm UTC
Due to storage plane maintenance, the system will operate with degraded performance. You may experience slow read operations during this period.
The expected duration is 48–60 hours and may include multiple restarts. Most restarts will last approximately 5 minutes, with at least one longer downtime expected to last 1–2 hours.
Affected services